Nauja PHP 5.5 versija – Interneto vizija

Nauja PHP 5.5 versija

11 komentarųPaskelbta: 2013-08-07 | Atnaujinta: 2020-05-18 | root

PHP Šiandien atnaujinome Serveriai.lt bei Hostingas.lt platformas ir pridėjome naują PHP versiją. PHP 5.5 – tai naujausia, greičiausia ir daugiausiai galimybių turinti PHP programavimo kalbos versija. Jei naudojate PHP 5.4, pereiti prie PHP 5.5 galite praktiškai be papildomų pastangų – tam tiesiog perjunkite PHP versiją per DirectAdmin valdymo pultą:

https://pagalba.iv.lt/PHP_versijos_keitimas

Jei naudojate senesnes PHP versijas, gali tekti atnaujinti svetainės PHP kodą. Į ką reikėtų atkreipti dėmesį išsamiai aprašyta PHP dokumentacijos svetainėje.

Migravimas iš PHP 5.4 į PHP 5.5:

http://php.net/manual/en/migration55.php

Migravimas iš PHP 5.3 į PHP 5.4:

http://php.net/manual/en/migration54.php

Migravimas iš PHP 5.2 į PHP 5.3:

http://php.net/manual/en/migration53.php

Kiti atlikti atnaujinimai:

  • Sistemos branduolys 2.6.32-358.14.1.el6
  • Apache httpd 2.2.25
  • PHP 5.3.27
  • PHP 5.4.17
  • PHP 5.5.1
  • ModSecurity 2.7.5
  • MySQL 5.5.32
  • ionCube PHP Loader 4.4.1
  • Pure-FTPd 1.0.36

Atkreipkite dėmesį į naują ModSecurity2 modulį, kuris saugo svetaines nuo bandymų įsilaužti.

Grįžti į sąrašą
11 komentarų
  • Arūnas -2013-08-07 11:23:31:

    Norėčiau paklausti, ar pakeitęs į nauja php 5.5 versija man nepabėgs puslapis, ar jis neissiderins? Nežinau ar tai klausimas kvailas ar rimtas tačiau aš šioje srityje esu tik naujokas dar puslapi kuriu su joomla 2.5 versija.

    root -2013-08-07 13:57:21:

    Priklauso nuo svetainės PHP kodo, kiek jis tvarkingai parašytas. Bet kuriuo atveju - galite patikrinti ir jei kas neveiks, greitai atkeisti PHP versiją atgal.

  • Albinas -2013-08-07 12:52:07:

    Gerai

  • Gedas -2013-08-07 14:07:24:

    sveiki, ar del atnaujimo gali mesti AJAX HTTP 403 klaidai?

    root -2013-08-07 14:11:16:

    Gali dėl ModSecurity2 - pabandykite išjungti jūsų svetainei trukdančią taisyklę arba visas taisykles:

    https://pagalba.iv.lt/Mod_security2

  • Povilas -2013-08-07 19:15:49:

    Sveiki,
    po atnaujinimo puslapis dirba puikiai. Tačiau negaliu prisijungti prie administratoriaus (dashbord) platformos error 404. Grąžinau "gerą" .htaccess tačiau prisijungti vistiek negaliu.
    Gal galite patarti kame galėtų būti problema?

    root -2013-08-08 06:08:07:

    Pabandykite į .htaccess failą įterpti tokį kodą:

    <IfModule mod_security2.c>
    SecRuleRemoveById 0:9999999
    </IfModule>

  • Vygandas -2013-08-08 07:55:13:

    Aš gaunu "Internal server error"
    Negalėtų būti šiaip sutapimas.
    (Ar įmanoma apache perktrauti ?)

    root -2013-08-08 07:58:24:

    Reikėtų išsamesnės informacijos diagnostikai, pvz., puslapio adresas. Ar galėtumėte ją atsiųsti į info@serveriai.lt?

  • Anatolijus -2013-08-09 11:53:12:

    Gerai kad atnaujinote Serveriai.lt bei Hostingas.lt platformas.
    Aš turiu tokį klausimą. Kodel po kiekvienos Joomla versijos atnaujinimo man
    tenka iš naujo redaguoti mano svetainės medžiagas, pvz. atstumus, išmeras,
    kalbos nustatymus ir t.t. ?
    Ar galima atjungti šitą atnaujinimą, kuris traukia iš manes laiką ir nuotaiką ?
    Mano svetainės url: http://www.manotv.puslapiai.lt
    su pagarba, Anatolijus

    root -2013-08-09 13:47:40:

    Mes atliekame tik serverio įrangos atnaujinimus. Svetainės atnaujinimus, kaip šiuo atveju, atlieka pats klientas ir tik jis gali spręsti kada ir ką svetainėje atnaujinti.

Parašyti komentarą
Atšaukti atsakymą
Sutinku, kad mano duomenys, pateikti komentare, bus rodomi viešai.