Ieškoti

PHP 7.3 ir MariaDB 10.3 palaikymas

3 komentarai Paskelbta: 2019-02-22 | Gintaras
MariaDB logotipoas su ruoniu

Nuo š. m. vasario Serveriai.lt bei Pro.Hostingas.lt paslaugų naudotojai jau gali išbandyti bei naudoti naujausią PHP 7.3 bei MariaDB 10.3 (MySQL 8 analogas) programinę įrangą.

Norint, kad Serveriai.lt arba Pro.Hostingas.lt paslaugoje talpinama svetainė naudotų naujausią duomenų bazių valdymo sistemos MariaDB versiją nieko papildomai daryti nereikia – ši programinė įranga yra atnaujinta ir įgalinta visuose minėtų paslaugų serveriuose. Norintiems išbandyti PHP 7.3 versiją – tereikia savo talpinimo plano ar serverio valdymo pulte aktyvuoti šią programinės įrangos versiją vos dviejų spragtelėjimų pagalba:

https://pagalba.iv.lt/PHP_versijos_keitimas

PHP logotipas

Po PHP 7.3 versijos įjungimo būtinai patikrinkite, ar visos svetainės talpinimo paslaugoje veikia korektiškai. Gali būti, kad Jūsų svetainės ar jos dalies (pvz.: dizaino temos, įskiepio) programinis kodas nebus pritaikytas veikti su naujausia PHP versija. Tačiau, jei naudojate populiarią turinio valdymo sistemą ir ją reguliariai atnaujinate, tikėtina, jog sulig artimiausiais atnaujinimais Jūsų svetainė galės veikti PHP 7.3 aplinkoje.
Išbandyti, o esant galimybei ir naudoti naujausią PHP versiją savo talpinimo paslaugoje išties verta. Dėl pagerintos PHP programinės įrangos optimizacijos Jūsų svetainė su naujausia PHP versija „užsikraus“ greičiau, nei lyginant identiškos svetainės veikimą senesnėse PHP versijose. Juo labiau, kai tai tik poros spragtelėjimų serverio valdymo pulte klausimas.

Grįžti į sąrašą
3 komentarai
  • Audrius - 2019-03-21 17:07:41:

    Ačiū, laukėme šito atnaujinimo.

  • Edvinas - 2019-12-19 07:32:38:

    Kiek naudingas gali būti šis php atnaujinimas atliekant SEO optimizacija ? Ar tai pagerintu svetaines uzsikrovimo greiti? Ar butu kitu privalumu? O gal yra priezasciu, kuomet neverta to daryti?

    Ačiū.

    https://edvinaspaliskis.lt/

    Gintaras - 2019-12-20 08:10:34:

    Labas, Edvinai. Visų pirma noriu atkreipti dėmesį, kad savo serveriuose jau turime PHP 7.4 versiją (7.3 nebėra naujausia mūsų siūloma). Na, o atsakant į tavo užduotus klausimus galiu pasakyti labai paprastai - visada rekomenduojame naudoti naujausią PHP programinės įrangos versiją. Daugiausiai privalumų (kurių kiekvieno čia, manau, neverta vardinti) naujausioje PHP versijoje atrastų programuotojai, tačiau kalbant apie svetainių savininkus ir paprastus lankytojus, žinoma, esminis privalumas yra pagerintas PHP programų vykdymo greitis, lyginant su senesnėmis PHP versijomis (ypač su 5.x šakos - net "plika akimi" matomas greitesnis užsikrovimas). Priežastis, kodėl nereikėtų naudoti naujausios PHP versijos galėtų būti nebent tik tai, kad talpinimo plane yra svetainių, kurios nepritaikytos iš kodo pusės veikti su naujausia PHP versija (jose po versijos perjungimo atsiras klaidų). Jei po PHP versijos aktyvavimo visos svetainės plane veikia sklandžiai, tuomet net nesvarstyk PHP versijos grąžinimo į senesnę! :)

Parašyti komentarą
Atšaukti atsakymą
Sutinku, kad mano duomenys, pateikti komentare, bus rodomi viešai.